Welcome!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Informational (vmware ) cara nak Enable 3D acceleration on VMWare windows guest from Arch-Linux host with Nvidia or ATI graphics card

Syedhafiz1234

Lance Corporal
DFM Member
Joined
Nov 14, 2021
Messages
117
Reaction score
262
DragonCoin
195
(vmware ) cara nak Enable 3D acceleration on VMWare windows guest from Arch-Linux host with Nvidia or ATI graphics card

bila noob mcm saya mencuba pelbagai teknik pembelajaran . mcm2 la problem timbul..
tapii ada jawapan hahaha best bila dpt godek2..

apabila running a guest OS with 3D acceleration enabled on VMWare Workstation (or player) on an Arch-based distro, ada la keluar notification mcm kat bawah


image2020-2-17_19-54-51.png


Cause​

Punca masalah boleh berbeza-beza. on Arch based distributions,
terutamanya pada komputer riba dengan kedua-dua kad grafik , t's most likely related to the discrete card not being used (or enabled easily).

Below are two solutions which have worked for me, for a Nvidia-based laptop (2018 Razer Blade 15) and an ATI Radeon laptop (2018 Lenovo e480).

Solutions​

Nvidia (Optimus) laptop - older laptops cards that support bumblebee and optirun​


Penyelesaian pertama melibatkan pemasangan bumblebee dan prefixing vmware atau vmplayer boleh laku dengan optirun. Cth

optirun -b primus vmware


a boleh mengubah suai (atau membuat salinan) fail .desktop dengan awalan yang diubah suai. Lihat di bawah (buat fail .desktop dan masukkan ke dalam folder pada laluan ):

example of a vmware-workstation-optirun.desktop file for launching vmware with optirun
1
2
3
4
5
6
7
8
9
10
11
12
[Desktop Entry]
Encoding=UTF-8
Name=VMware Workstation (OPTIRUN)
Comment=Run and manage virtual machines
Exec=optirun -b primus /usr/bin/vmware %U
Terminal=false
Type=Application
Icon=vmware-workstation
StartupNotify=true
Categories=System;
MimeType=application/x-vmware-vm;application/x-vmware-team;application/x-vmware-enc-vm;x-scheme-handler/vmrc;
Path=

Nvidia (Optimus) laptop - newer laptops with cards that support video-hybrid-intel-nvidia-prime​

For laptops with newer cards (for example my Razer Blade 15 with an RTX 2080) you should be able to prefix the vmware or vmplayer executable with prime-run. E.g.

prime-run vmware

You can also modify (or make a copy) of the .desktop file with a modified prefix. See below (create a .desktop file and put in a folder on you path):

example of a vmware-workstation-optirun.desktop file for launching vmware with optirun
1
2
3
4
5
6
7
8
9
10
11
12
[Desktop Entry]
Encoding=UTF-8
Name=VMware Workstation (PRIME)
Comment=Run and manage virtual machines
Exec=prime-run /usr/bin/vmware %U
Terminal=false
Type=Application
Icon=vmware-workstation
StartupNotify=true
Categories=System;
MimeType=application/x-vmware-vm;application/x-vmware-team;application/x-vmware-enc-vm;x-scheme-handler/vmrc;
Path=

ATI based laptop - allow blacklisted drivers​

Kini, ATI mempunyai support linux yang lebih baik (setakat ini...) namun, pada e480 saya, saya tidak dapat memastikan 3D berfungsi sehingga saya menjumpai siaran ini oleh / dev/blog.

Nampaknya VMWare m menyenaraihitamkan beberapa driver. Nasib baik kita boleh membuat asal penyenaraian hitam ini dengan mengubah suai fail keutamaan dengan menambahkan yang berikut pada ~/.vmware/preferences:

Add the following line to the ~/.vmware/preferences file
mks.gl.allowBlacklistedDrivers = TRUE

selamat mencuba pssst saya masih noob pasal opensource dan cuba ke arah pembelajaran lebih baik
 

Aiman

Sub Mod
DFM Sub Moderator
Joined
May 30, 2021
Messages
4,283
Reaction score
15,983
DragonCoin
26,824
Fire Red Dragon
Black Dragon
(vmware ) cara nak Enable 3D acceleration on VMWare windows guest from Arch-Linux host with Nvidia or ATI graphics card

bila noob mcm saya mencuba pelbagai teknik pembelajaran . mcm2 la problem timbul..
tapii ada jawapan hahaha best bila dpt godek2..

apabila running a guest OS with 3D acceleration enabled on VMWare Workstation (or player) on an Arch-based distro, ada la keluar notification mcm kat bawah


image2020-2-17_19-54-51.png


Cause​

Punca masalah boleh berbeza-beza. on Arch based distributions,
terutamanya pada komputer riba dengan kedua-dua kad grafik , t's most likely related to the discrete card not being used (or enabled easily).

Below are two solutions which have worked for me, for a Nvidia-based laptop (2018 Razer Blade 15) and an ATI Radeon laptop (2018 Lenovo e480).

Solutions​

Nvidia (Optimus) laptop - older laptops cards that support bumblebee and optirun​


Penyelesaian pertama melibatkan pemasangan bumblebee dan prefixing vmware atau vmplayer boleh laku dengan optirun. Cth

optirun -b primus vmware


a boleh mengubah suai (atau membuat salinan) fail .desktop dengan awalan yang diubah suai. Lihat di bawah (buat fail .desktop dan masukkan ke dalam folder pada laluan ):

example of a vmware-workstation-optirun.desktop file for launching vmware with optirun
1
2
3
4
5
6
7
8
9
10
11
12
[Desktop Entry]
Encoding=UTF-8
Name=VMware Workstation (OPTIRUN)
Comment=Run and manage virtual machines
Exec=optirun -b primus /usr/bin/vmware %U
Terminal=false
Type=Application
Icon=vmware-workstation
StartupNotify=true
Categories=System;
MimeType=application/x-vmware-vm;application/x-vmware-team;application/x-vmware-enc-vm;x-scheme-handler/vmrc;
Path=

Nvidia (Optimus) laptop - newer laptops with cards that support video-hybrid-intel-nvidia-prime​

For laptops with newer cards (for example my Razer Blade 15 with an RTX 2080) you should be able to prefix the vmware or vmplayer executable with prime-run. E.g.

prime-run vmware

You can also modify (or make a copy) of the .desktop file with a modified prefix. See below (create a .desktop file and put in a folder on you path):

example of a vmware-workstation-optirun.desktop file for launching vmware with optirun
1
2
3
4
5
6
7
8
9
10
11
12
[Desktop Entry]
Encoding=UTF-8
Name=VMware Workstation (PRIME)
Comment=Run and manage virtual machines
Exec=prime-run /usr/bin/vmware %U
Terminal=false
Type=Application
Icon=vmware-workstation
StartupNotify=true
Categories=System;
MimeType=application/x-vmware-vm;application/x-vmware-team;application/x-vmware-enc-vm;x-scheme-handler/vmrc;
Path=

ATI based laptop - allow blacklisted drivers​

Kini, ATI mempunyai support linux yang lebih baik (setakat ini...) namun, pada e480 saya, saya tidak dapat memastikan 3D berfungsi sehingga saya menjumpai siaran ini oleh / dev/blog.

Nampaknya VMWare m menyenaraihitamkan beberapa driver. Nasib baik kita boleh membuat asal penyenaraian hitam ini dengan mengubah suai fail keutamaan dengan menambahkan yang berikut pada ~/.vmware/preferences:

Add the following line to the ~/.vmware/preferences file
mks.gl.allowBlacklistedDrivers = TRUE

selamat mencuba pssst saya masih noob pasal opensource dan cuba ke arah pembelajaran lebih baik
Tq share ilmu ..baik ni..
 
Top